Forum
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: noSAN Help Needed

noSAN Help Needed 2 months 3 weeks ago #1598

My company is looking for options for hyper-converged virtualization. We have a working demo for Windows Server 2016 Datacenter Ed. but the monthly licensing is more than the one time server expense. VMWare is much cheaper but doesn't have a hyper-converged option (as far as we can tell). Having to set up an iSCSI share on a third server is not something we want. In the interest of options, research brought us to Citrix XenServer with HA-Lizard noSAN. The idea is exactly what we are looking for and the cheapest option yet. Trying to setup a demo we've had some trouble but we still want a working demo before we make a final decision on it.

XenServer 7.4 with trial licencing
HA-Lizard 2.1.3 noSAN
Demoing on ESXi 6.5 (tried and failed on a Hyper-V 2016 cluster)
Recommended 4 NICs with 2 bonded for iSCSI

Going through the HA-Lizard installer we get lots of command syntax errors and warnings but we can make it through the installer. To get through the installer we cannot use the local SR (the installer can't access access it). We manually pointed the installer at /dev/sdb. It gets to looking/listening for the peer node but it won't find the peer. If we type 'yes' to bypass the test connection, we can add the iSCSI share to the XS pool but the slave portion fails and cannot be repaired. Attached are the installer outputs.
Attachments:
Last Edit: 2 months 3 weeks ago by Christian.
The administrator has disabled public write access.

noSAN Help Needed 2 months 3 weeks ago #1599

The installation appears to be largely successful. There is an error from the firewall configuration which is likely resultant from running the installer more than once. The firewall appears to be configured ok though since drbd does connect at the end of the installation.

Also, I cannot comment on why a local SR is not found. I am guessing that there was none to begin with. Manually entering sdb is perfectly fine appears to have worked.

If you are still having trouble, send an email with your contact details and timezone to This email address is being protected from spambots. You need JavaScript enabled to view it..
The administrator has disabled public write access.

noSAN Help Needed 2 months 3 weeks ago #1600

I see where it failed to add the firewall rule. What is the proper firewall rule to add? I go to /etc/sysconfig/iptables and tried adding
A RH-Firewall-1-INPUT -s 10.10.10.0/24 -j ACCEPT
Then restarting iptables. I get the same issues with a fresh install as well. Since the demo is in ESXi1 I have snapshots I have been going back to.
I also send any email but if this gets solved it would be a good resource.
The administrator has disabled public write access.

noSAN Help Needed 2 months 3 weeks ago #1601

I've confirmed that the latest XenServer release has added two chains to the default firewall which is causing the installer script to return 3 positions to insert the rule into. A fix will be posted tonight or tomorrow.
The administrator has disabled public write access.

noSAN Help Needed 2 months 3 weeks ago #1602

Can you give this a try and report back your results?

halizard.org/release/noSAN-combined/hali...osan_installer_2.1.4

Thanks
The administrator has disabled public write access.

noSAN Help Needed 2 months 3 weeks ago #1603

Tried it out tonight. The firewall error went away but I am still getting an ARP error and a CURL error. See attached.
Attachments:
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.083 seconds