Forum

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /homepages/13/d467848118/htdocs/templates/cleanout/vertex/responsive/responsive_mobile_menu.php on line 158
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC:

Cannot reattach iscsi after upgrade 4 months 1 week ago #3103

  • Giorgio Catena
  • Giorgio Catena's Avatar Topic Author
  • Offline
  • Posts: 32
Hi,
we did perform a regular xcp-ng update (running xcp-ng 8.2), starting from the master node.
After rebooting the PDB of the shared storage is not plugged anymore giving back the error SR_BACKEND_FAILURE_47 as follows:

Mar 6 10:31:37 xen1 iscsi-ha: 16102 iSCSI target: tgtd status = OK. [ active (running) since Wed 2024-03-06 10:12:32 CET; 19min ago ]
Mar 6 10:31:37 xen1 iscsi-ha: 16102 local_ip_list: Local IP list returned 127.0.0.1#01210.10.10.1#01210.10.10.3#012172.16.56.5#01210.20.10.2
Mar 6 10:31:37 xen1 iscsi-ha: 16102 CHECKING IP 127.0.0.1
Mar 6 10:31:37 xen1 iscsi-ha: 16102 CHECKING IP 10.10.10.1
Mar 6 10:31:37 xen1 iscsi-ha: 16102 CHECKING IP 10.10.10.3
Mar 6 10:31:37 xen1 iscsi-ha: 16102 Virtual IP: 10.10.10.3 discovered on host xen1
Mar 6 10:31:37 xen1 iscsi-ha: 16102 send_replication_network_arp: Sending ARP update to peer
Mar 6 10:31:37 xen1 iscsi-ha: 16102 send_replication_network_arp: IP address list for [ xapi1 ] = [ 10.10.10.1#01210.10.10.3 ]
Mar 6 10:31:37 xen1 iscsi-ha: 16102 send_replication_network_arp: Updating ARP for device [ xapi1 ] IP [ 10.10.10.1 ]
Mar 6 10:31:38 xen1 iscsi-ha-NOTICE-/etc/iscsi-ha/init/iscsi-ha.mon: ARPING 10.10.10.1 from 10.10.10.1 xapi1
Mar 6 10:31:38 xen1 iscsi-ha-NOTICE-/etc/iscsi-ha/init/iscsi-ha.mon: Sent 2 probes (2 broadcast(s))
Mar 6 10:31:38 xen1 iscsi-ha-NOTICE-/etc/iscsi-ha/init/iscsi-ha.mon: Received 0 response(s)
Mar 6 10:31:38 xen1 iscsi-ha: 16102 send_replication_network_arp: Updating ARP for device [ xapi1 ] IP [ 10.10.10.3 ]
Mar 6 10:31:39 xen1 iscsi-ha-NOTICE-/etc/iscsi-ha/init/iscsi-ha.mon: ARPING 10.10.10.3 from 10.10.10.3 xapi1
Mar 6 10:31:39 xen1 iscsi-ha-NOTICE-/etc/iscsi-ha/init/iscsi-ha.mon: Sent 2 probes (2 broadcast(s))
Mar 6 10:31:39 xen1 iscsi-ha-NOTICE-/etc/iscsi-ha/init/iscsi-ha.mon: Received 0 response(s)
Mar 6 10:31:39 xen1 iscsi-ha: 16102 Skipping replication_link_check DRBD_LINK_OK=[true] STATE=[master] MANUAL_MODE=[off]
Mar 6 10:31:40 xen1 iscsi-ha: iscsi-ha Watchdog: iscsi-ha running - OK
Mar 6 10:31:43 xen1 iscsi-ha-ERROR-/etc/iscsi-ha/init/iscsi-ha.mon: Error code: SR_BACKEND_FAILURE_47
Mar 6 10:31:43 xen1 iscsi-ha-ERROR-/etc/iscsi-ha/init/iscsi-ha.mon: Error parameters: , The SR is not available [opterr=[Errno 2] No such file or directory: '/dev/disk/by-scsid/360000000000000000e0000000001000a'],


Could you please tell me which kind of action could I perform to fix the problem?

Please Log in or Create an account to join the conversation.

Cannot reattach iscsi after upgrade 4 months 1 week ago #3104

  • Giorgio Catena
  • Giorgio Catena's Avatar Topic Author
  • Offline
  • Posts: 32
I did also read the last post to turn off the autostart and manually restart the iscsi-ha but keeps giving back the same error.

Please Log in or Create an account to join the conversation.

Cannot reattach iscsi after upgrade 4 months 3 days ago #3169

Hi,

Try restarting the server with iscsi-ha and iscsi-ha-watchdog disabled, wait about 2 minutes after the server boots and then stop the iscsid service and after a few seconds start it and look in /dev/disk/by-scsid/ to see if the missing ids appears. This solution worked for me yesterday

Please Log in or Create an account to join the conversation.

Cannot reattach iscsi after upgrade 1 month 4 weeks ago #5249

Could anybody confirm which XCP-NG 8.2.1 patch level is currently used with HA-Lizard successful?

I am still sticking with patch level September 2023 as I had fears to update my two production clusters due to these reported issues.

Best regards
Andreas

Please Log in or Create an account to join the conversation.

Cannot reattach iscsi after upgrade 1 month 4 weeks ago #5250

  • Giorgio Catena
  • Giorgio Catena's Avatar Topic Author
  • Offline
  • Posts: 32
Hi, My solution was to unmount the linux link aggregation made by xapi, leaving a single 10G nic and reconfigure the ha config to speak on that link and not to the xapi defined one.

Please Log in or Create an account to join the conversation.

Cannot reattach iscsi after upgrade 1 month 4 weeks ago #5251

Hi, My solution was to unmount the linux link aggregation made by xapi, leaving a single 10G nic and reconfigure the ha config to speak on that link and not to the xapi defined one.

Do you use XCP-NG or Citrix Hypervisor?
Which security Patch Level?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2