Forum

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /homepages/13/d467848118/htdocs/templates/cleanout/vertex/responsive/responsive_mobile_menu.php on line 158
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC:

Cannot reattach iscsi after upgrade 1 month 5 days ago #5253

Just ran into this issue:

Have restarted hosts and tried repair srdb to no avail.

My NIC's are bonded.

DRBD is up and running.

`iscsi-cfg` status shows:

```
| iSCSI-HA Version IHA_2.2.5 |
| Mon Jun 10 11:18:23 EDT 2024 |

| iSCSI-HA Status: Running 28854 |
| Last Updated: Mon Jun 10 11:18:08 EDT 2024 |
| HOST ROLE: MASTER |
| DRBD ROLE: iscsi1=Primary |
| DRBD CONNECTION: iscsi1 in Connected state |
| DRBD Disk State: iscsi1 in UpToDate/UpToDate disk state |
| ISCSI TARGET: Running [expected running] |
| VIRTUAL IP: 172.16.1.3 is local |
Control + C to exit


| DRBD Status |

| version: 8.4.10 (api:1/proto:86-101) |
| srcversion: CE41F2FAB70AE3534BF40A6 |
| 1: cs:Connected ro:Primary/Secondary ds:UpToDate/UpToDate C r
|
| ns:0 nr:10261104 dw:10261104 dr:396 al:0 bm:0 lo:0 pe:0 ua:0 ap:0 ep:1 wo:f oos:0 |
```

Please Log in or Create an account to join the conversation.

Cannot reattach iscsi after upgrade 1 month 5 days ago #5254

I'm also getting:

Jun 10 11:28:10 xen1 iscsid: Connection196:0 to [target: iqn.2015.com.halizard:noSAN, portal: 172.16.1.3,3260] through [iface: default] is operational now
Jun 10 11:28:15 xen1 iscsid: Connection196:0 to [target: iqn.2015.com.halizard:noSAN, portal: 172.16.1.3,3260] through [iface: default] is shutdown.

Please Log in or Create an account to join the conversation.

Cannot reattach iscsi after upgrade 1 month 4 days ago #5255

My Current workaround is to run "service tgtd restart" on the master after rebooting xcp hosts. This will bring back shared storage.

Unfortunately it seems to be we need to search for an alternative solution as the promise of HA-Lizard and iSCSI-HA is not anymore valid due to this "bug".

We had last weekend a power outage on our second production site and after fully automated shutdown with our online UPC the pool came up after the batteries were loaded and power had returned.

However, our VMs could not boot without backing storage... :-(

Please Log in or Create an account to join the conversation.

Last edit: by ajmind.

Cannot reattach iscsi after upgrade 1 month 4 days ago #5256

I discovered late yesterday that switching master to a different host then having to manually switch DRBD then putting that back to automatic got me back up and running, at least until the next reboot, and this is with me doing a yum history undo.

I haven't tried switching the master back to the original master yet.

Please Log in or Create an account to join the conversation.

Cannot reattach iscsi after upgrade 1 month 4 days ago #5257

  • Giorgio Catena
  • Giorgio Catena's Avatar Topic Author
  • Offline
  • Posts: 32
Have you tried to unconfigure the bond and leave only 1 nic working?

Please Log in or Create an account to join the conversation.

Cannot reattach iscsi after upgrade 3 weeks 5 days ago #5260

Hi Giorgio,

Please see my post here regarding this.
www.halizard.com/forum/software-support/...-reboot?start=6#5258

Cheers
Nathan

Please Log in or Create an account to join the conversation.

Last edit: by Nathan Scannell.
  • Page:
  • 1
  • 2