Forum
Welcome, Guest
Username: Password: Remember me

TOPIC: Killing all processes now?

Killing all processes now? 4 months 3 weeks ago #1378

I have a 2 node system up and running but I keep getting the following emails:

****
xe_wrapper: COMMAND: xe host-param-list uuid=dbe84892-056f-4147-b9df-d4cf303658dc Has reached the maximum allowable time of 10 seconds. Killing all processes now!

Pool UUID : 7439dccd-2f58-8063-d5ba-9b1525f844b9
Pool Name-Label : MRG
Pool Master UUID: dbe84892-056f-4147-b9df-d4cf303658dc
Host Name-Label : XENSVR-002
Host UUID : 04554bcb-95d2-4ca0-9af7-81f1167f9a37
Pool Master : false
Host Name-Label : XENSVR-001
Host UUID : dbe84892-056f-4147-b9df-d4cf303658dc
Pool Master : true
****

I also get another email with the following:

****
update_global_conf_params: Failed to update global pool configuration settings in /etc/ha-lizard/ha-lizard.pool.conf - Check Configuration!
****

Thanks in advance.
Last Edit: 4 months 3 weeks ago by Robert Adams.
The administrator has disabled public write access.

Killing all processes now? 4 months 3 weeks ago #1379

Looks like the xen Api is not responding within 10 seconds so we kill any threads that were stuck in a waiting state. You can try extending the timer in the configuration to something longer than 10 seconds, but that is only recommended if you are running on slow hardware, otherwise check your hosts to see what could be causing xapi to lag.
The administrator has disabled public write access.

Killing all processes now? 4 months 3 weeks ago #1399

I'm not running slow hardware. Transport is on 10Gbe Nics.
How do you suggest checking xapi?

Thanks.
The administrator has disabled public write access.

Killing all processes now? 4 months 3 weeks ago #1403

First place would be to check the xenserver logs around the timestamp of the email alert. You should be able to see what xapi was busy doing
The administrator has disabled public write access.

Killing all processes now? 4 months 2 weeks ago #1404

Ended up restarting the toolstack from the cli on both machines. That seemed to do the trick.

Thanks.
The administrator has disabled public write access.

Killing all processes now? 4 months 6 days ago #1408

So it would seem that when I look at the running processes, vhd-util is running 100% on the affected server. Is it possible that this is due to vm migration and or vm backups?
The administrator has disabled public write access.
Time to create page: 0.069 seconds