Forum
Welcome, Guest
Username: Password: Remember me
This is the optional category header for the Suggestion Box.

TOPIC: iSCSI Target LUN discover error

iSCSI Target LUN discover error 5 years 2 months ago #101

When trying to attach ISCSI SR from XEN Pool i get an error when pressing "DISCOVER LUNs" showing that not LUN is found.

Te status is:
*************************************************************************
iSCSI-HA Status: Version: IHA_1.2.16 S99iscsi-ha (pid 7491 7475) is running...
HOST ROLE:MASTER
DRBD ROLE:iscsi1=Primary
DRBD CONNECTION: iscsi1 in Connected state
ISCSI TARGET:tgtd (pid 8106 8104) is running...
VIRTUAL IP:10.10.10.3 is local
*************************************************************************
*************************************************************************
iSCSI-HA Status: Version: IHA_1.2.16 S99iscsi-ha (pid 7403 7396) is running...
HOST ROLE: SLAVE
VIRTUAL IP:10.10.10.3 is not local
ISCSI TARGET:tgtd is stopped
DRBD ROLE:iscsi1=Secondary
DRBD CONNECTION: iscsi1 in Connected state
*************************************************************************

In slave the TGT is stopped (i don´t know why)

Any help?
Last Edit: 5 years 2 months ago by soylor.
The administrator has disabled public write access.

iSCSI Target LUN discover error 5 years 2 months ago #103

The iscsi target (TGT) should be stopped on the slave host, so, the status of both of your hosts is perfectly fine and normal.

Are you successfully completing "Discover IQNs" before trying to discover LUNS?

ALso, have your LVM filters been set per howto and caches cleared:
rm –f /etc/lvm/cache/.cache && vgscan

Lastly - can you post the backing device configuration you have in tgtd.conf?
The administrator has disabled public write access.

iSCSI Target LUN discover error 5 years 2 months ago #104

It was a minus character (-) error because copy-paste.

Now everything works fine.

Thanks.
Last Edit: 5 years 2 months ago by Salvatore Costantino.
The administrator has disabled public write access.

iSCSI Target LUN discover error 6 months 3 days ago #1623

I have a similar problem.
I can discover iqn, but show message that No Lun was found.

Any Help?
The administrator has disabled public write access.

iSCSI Target LUN discover error 6 months 1 day ago #1624

This could happen if during the installation of xenserver you choose more than 1 storage device for local SR and then when installing halizard choose to have the local SR converted to halizard storage. Do you recall whether this was the case?
The administrator has disabled public write access.

iSCSI Target LUN discover error 5 months 4 weeks ago #1625

I was using the How-to and following the steps. There was no option to convert local SR.
Then I used the full installation package and it worked.
Thank you for your help.
The administrator has disabled public write access.
Time to create page: 0.085 seconds