Forum
Welcome, Guest
Username: Password: Remember me
This is the optional category header for the Suggestion Box.
  • Page:
  • 1
  • 2

TOPIC: Insert custom field used to toggle HA on/off ERR

Insert custom field used to toggle HA on/off ERR 3 months 1 week ago #1411

Hello,

I am attempting to install HA Lizzard on a Xen 7.1 system and execute the following.

Insert the default pool settings into the XAPI database (this steps needs to be completed only one time on any of the pool hosts)

/etc/ha-lizard/scripts/ha-cfg insert

- Insert custom field used to toggle HA on/off

xe pool-param-add uuid=`xe pool-list –minimal` param-name=other-config XenCenter.CustomFields.ha-lizard-enabled=false

And I get this:

Last login: Tue Sep 5 14:42:40 2017
[root@xenserver02 ~]# xe pool-param-add uuid=`xe pool-list –minimal` param-name=other-config XenCenter.CustomFields.ha-lizard-enabled=false
Error: Unknown field '–minimal'
The uuid you supplied was invalid.
type: pool
uuid:

Any help would be appreciated! Thanks much
The administrator has disabled public write access.

Insert custom field used to toggle HA on/off ERR 3 months 1 week ago #1412

looks like you are missing a hyphen in your command

it should be "-- minimal" (2 hyphens)
The administrator has disabled public write access.

Insert custom field used to toggle HA on/off ERR 3 months 1 week ago #1413

Thanks,

I went back in and tried again with the double dash but still no luck.

[root@xenserver02 ~]# xe pool-param-add uuid=`xe pool-list -–minimal` param-name=other-config XenCenter.CustomFields.ha-lizard-enabled=false
Syntax error:
For usage run: 'xe help'
The uuid you supplied was invalid.
type: pool
uuid:
The administrator has disabled public write access.

Insert custom field used to toggle HA on/off ERR 3 months 1 week ago #1414

Looks like the pool UUID is still returning something invalid.
To rule out any formatting issues on this forum, I have re-input the below from scratch.

Try running both on your host.

POOL_UUID=$(xe pool-list -–minimal)

xe pool-param-add uuid=$POOL_UUID param-name=other-config XenCenter.CustomFields.ha-lizard-enabled=false
The administrator has disabled public write access.

Insert custom field used to toggle HA on/off ERR 3 months 5 days ago #1415

Ok that worked thank you! I went to the next steps and ran into this.

Start the service in the background
/etc/ha-lizard/scripts/ha-lizard.mon &

COMMAND WAS WRONG, used this instead /etc/ha-lizard/init/ha-lizard.mon &

Checked status and received this.

[root@xenserver02 ~]# /etc/ha-lizard/scripts/ha-cfg status
timeout
| ha-lizard Version: 2.1.3 |
| Operating Mode: Mode [ 2 ] Managing All VMs in Pool |
| Host Role: slave |
| Pool UUID: |
| Host UUID: |
| Master UUID: |
| Daemon Status: ha-lizard is not running [ STOPPED ] |
| Watchdog Status: ha-lizard-watchdog is not running [ STOPPED ] |
| HA Enabled: TIMEOUT |
Pool HA Status: TIMEOUT

Is this expected? I started the service.
Last Edit: 3 months 5 days ago by rustedgear.
The administrator has disabled public write access.

Insert custom field used to toggle HA on/off ERR 3 months 5 days ago #1416

FYI
You should not be launching the monitor unless you are in a NON-XenServer environment (which is rare).

Can you point out which doc that was in? It should be noted with something stating that that step in only for non-xenserver dom0s.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.279 seconds