Forum
Welcome, Guest
Username: Password: Remember me
This is the optional category header for the Suggestion Box.
  • Page:
  • 1

TOPIC: HA-Liazard - nosan, slave has been fenced

HA-Liazard - nosan, slave has been fenced 9 months 3 weeks ago #1591

  • Costas Pavlou
  • Costas Pavlou's Avatar Topic Author
  • Offline
  • Posts: 4
Hi all, I've had my test cluster working well for months, today I tried to move the network config over to a new subnet, after changing both the hosts management ip's from old to new subnet, the slave host boots but won't join the pool, after looking at the screen it doesn't show any nics, says it's in maint mode, and throws an error if I try exit maint mode. The iscsi-ha service is failing to start, bonded network is unchanged and working. I've deleted the "/etc/systemd/system/tgtd.service.d/local.conf"
When I run ha-cfg status from the master it shows enabled.

I think I have made an error when configuring the network settings on the slave, I've put in an incorrect gateway...would this be the result? Does it use the gateway as the heartbeat?

How can I now manually change the salves network config via the terminal console?

xe pif-list on the slave times out and brings no results.

Please Log in or Create an account to join the conversation.

Last edit: by Costas Pavlou.

HA-Liazard - nosan, slave has been fenced 9 months 3 weeks ago #1594

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 539
You can try this from the shell. Replace the variables with your data

xe-reset-networking --ip=$IP --netmask=$NETMASK --gateway=$GATEWAY --dns=$DNS --mode=$MODE

Please Log in or Create an account to join the conversation.

  • Page:
  • 1