Forum
Welcome, Guest
Username: Password: Remember me
This is the optional category header for the Suggestion Box.
  • Page:
  • 1

TOPIC:

VM Automatically Starts 5 months 2 days ago #2477

  • Christopher Tautua
  • Christopher Tautua's Avatar Topic Author
  • Offline
  • Posts: 23
Hi there,

I have this problem when i am trying to shutdown VMs it auto restarts and it.

Please anyone can show me how this can be fixed

Thanks

Please Log in or Create an account to join the conversation.

VM Automatically Starts 5 months 2 days ago #2478

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 703
Simplest solution is to temporarily disable HA. Below command will globally disable HA for the cluster/pool. Run it from any of the hosts in the pool.
ha-cfg ha-disable

The root cause of your issue is likely related to using default settings. By default, (on a new installation), ALL VMs are treated as having HA enabled if HA is enabled for the pool. This behavior is controlled by the setting GLOBAL_VM_HA which is set to 1 on a new installtion. If you require more control over which VMs have HA enabled, you should set this to 0
ha-cfg set global_vm_ha 0

Once this has been set to 0, you will be required to individually set HA per VM using
ha-cfg set-vm-ha <vm-name> true|false

Alternatively, you can individually set HA per VM from within XenCEnter or XCP-ngcenter, assuming you have exposed the custom parameter "ha-lizard-enabled"

Please Log in or Create an account to join the conversation.

  • Page:
  • 1