Forum
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Problem reinstalling HA-Lizard after xcp-ng upgrade 1 month 4 minutes ago #2686

  • José Queiroz
  • José Queiroz's Avatar Topic Author
  • Offline
  • Posts: 2
Hi,
I'm stuck in the process of upgrading a pool of 2 xcp-ng servers to version 8.2.1.
I followed the steps suggested here: www.halizard.com/forum/software-support/...xcp-ng-8-0-beta#1955
After upgrading the master node, running the reinstallation script, I got a message that iscsi-ha-2.2.5-1.rpm couldn't get installed, as it have failed dependecies on drbd84-uitls-sysvinit, which is not present on any of the configured repositories.

I remember that last week I installed a new pool from scratch, and had no issues. After investigating a while, I came to see that the installation script uses the "tgz" package, and the reinstallation uses the "rpm" version, which have this dependency problem.

What should I do now? May I just manually install the tgz version of iscs-ha package, and run the installation script again?

Thanks for the attention.

Please Log in or Create an account to join the conversation.

Problem reinstalling HA-Lizard after xcp-ng upgrade 4 weeks 1 day ago #2688

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 720
You can use the tgz install method to get past this, or install the missing dependency before running the post-update script. Either should work.
The following user(s) said Thank You: José Queiroz

Please Log in or Create an account to join the conversation.

Problem reinstalling HA-Lizard after xcp-ng upgrade 4 weeks 1 day ago #2689

  • José Queiroz
  • José Queiroz's Avatar Topic Author
  • Offline
  • Posts: 2
Hmm. Where can I find the missing package? It didn't find it in any of the configured repositories.

Please Log in or Create an account to join the conversation.

Problem reinstalling HA-Lizard after xcp-ng upgrade 4 weeks 15 hours ago #2690

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 720
Sorry about that. All versions in both tgz and rpm are available here.

halizard.org/release/ha-lizard/
halizard.org/release/iscsi-ha/

Please Log in or Create an account to join the conversation.

Problem reinstalling HA-Lizard after xcp-ng upgrade 3 weeks 3 days ago #2693

Please check and install first the depencies of SysVinit.

www.halizard.com/forum/suggestion-box/73...ad-page?start=6#2647
The following user(s) said Thank You: José Queiroz

Please Log in or Create an account to join the conversation.

  • Page:
  • 1